# Table Of Contents

Table Of Contents ........................................................................................................... 2

1. Introduction .................................................................................................................. 4
   Where to Get Help ........................................................................................................... 4

2. Overview and Concepts ............................................................................................... 4
   Matches and Match Rounds ............................................................................................... 5
   Fields and Field Sets ....................................................................................................... 6
   Audience, Pit, and Field Displays ....................................................................................... 7

3. Software Installation and Hardware Setup .................................................................... 7
   Minimum Requirements ..................................................................................................... 8
   Installation ......................................................................................................................... 8
   Setting Up the Hardware .................................................................................................. 8
   Small Tournament Example with Pit Display ................................................................. 9
   Medium Tournament Example ......................................................................................... 11
   Network Setup ................................................................................................................ 12

4. Creating a Tournament ............................................................................................... 12
   Preset Options Page ....................................................................................................... 14
   General Settings Page ................................................................................................... 15
   Game Scoring Configuration Page .................................................................................. 15
   Team Setup Page ............................................................................................................ 15
   Elimination Tournament Setup Page ............................................................................... 16
   Field Set Page ............................................................................................................... 17
   Skills Challenge Fields Page ......................................................................................... 17
   Pit Display Page ............................................................................................................. 17
   Schedule Setup Page ..................................................................................................... 18
   Create Matches Page ..................................................................................................... 19
   Awards Setup Page ........................................................................................................ 19
   Web Publishing Setup Page ............................................................................................ 20
   Setup Wizard Complete .................................................................................................. 21
   Connecting the Match Controllers to Tournament Manager ......................................... 21
   Starting the Audience Display Program ......................................................................... 22
   Starting the Pit Display Program .................................................................................... 23

5. Running An Event ......................................................................................................... 24
   Main Window .................................................................................................................. 24
   Before The Beginning of the Event ................................................................................. 24
   Running Practice and Qualification Matches ............................................................... 25
   Running Skills Challenge Matches ............................................................................... 28
   Alliance Selection .......................................................................................................... 29
   Running Elimination Matches ....................................................................................... 30
   Running Finals Matches ............................................................................................... 31
   Assigning Award winners ............................................................................................. 31
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Displaying Award Winners &amp; Other Slides</td>
<td>33</td>
</tr>
<tr>
<td>Finishing The Event</td>
<td>34</td>
</tr>
<tr>
<td>Shutting Down the Software</td>
<td>35</td>
</tr>
<tr>
<td><strong>6. Advanced Topics</strong></td>
<td>35</td>
</tr>
<tr>
<td>Sponsor Logos</td>
<td>36</td>
</tr>
<tr>
<td>Large Sponsor Images</td>
<td>36</td>
</tr>
<tr>
<td>Small Sponsor Images</td>
<td>36</td>
</tr>
<tr>
<td>Team Check In</td>
<td>36</td>
</tr>
<tr>
<td>Inspection</td>
<td>37</td>
</tr>
<tr>
<td><strong>Multiple Divisions</strong></td>
<td>38</td>
</tr>
<tr>
<td>Using Multiple Tournament Files</td>
<td>38</td>
</tr>
<tr>
<td>Using a Single Tournament File</td>
<td>39</td>
</tr>
<tr>
<td><strong>Built-In Web Server</strong></td>
<td>40</td>
</tr>
<tr>
<td>League Play</td>
<td>42</td>
</tr>
<tr>
<td>League Play Concepts</td>
<td>42</td>
</tr>
<tr>
<td>Running VEX League Events with Tournament Manager</td>
<td>42</td>
</tr>
<tr>
<td>Rankings at League Events</td>
<td>42</td>
</tr>
<tr>
<td>Alliance Selection and the Elimination Tournament</td>
<td>43</td>
</tr>
<tr>
<td><strong>VEX TEXT</strong></td>
<td>44</td>
</tr>
<tr>
<td>Overview</td>
<td>44</td>
</tr>
<tr>
<td>Setup Procedures</td>
<td>44</td>
</tr>
<tr>
<td>Tournament Manager on the Raspberry Pi</td>
<td>46</td>
</tr>
<tr>
<td>Raspberry Pi Tournament Manager Quick Start</td>
<td>46</td>
</tr>
<tr>
<td><strong>Appendix A - Frequently Asked Questions</strong></td>
<td>48</td>
</tr>
<tr>
<td>General</td>
<td>49</td>
</tr>
<tr>
<td>Alliance Selection</td>
<td>50</td>
</tr>
<tr>
<td>Audience, Pit, and Field Displays</td>
<td>52</td>
</tr>
<tr>
<td>Reports</td>
<td>52</td>
</tr>
<tr>
<td>Web Server</td>
<td>52</td>
</tr>
</tbody>
</table>
1. Introduction

The VEX Tournament Manager is a custom software package designed to simplify and automate many of the tasks associated with running a VEX Robotics tournament. The program is flexible and modular and designed to work for small, local tournaments as well as large, international competitions and everything in between. Some of the main features of the Tournament Manager software are:

- Create practice and qualification match schedules based on a team list
- Run matches with automatic enabling and disabling of team robots for accurate match timing
- Enter and calculate match scores
- Team rankings are automatically determined based on qualification match scores
- Conduct an alliance selection process where a selected number of top-ranked teams can choose partners to compete in an elimination tournament
  - Bye rounds are automatically used if necessary for the highest-ranked alliances
  - Alliances are automatically advanced to the next round of play after winning 2 matches
- Hold an elimination tournament with up to 16 alliances made up of 1 to 3 teams each
- Publish match results online
- Display information such as rankings, match time clock, schedules, and match scores to team members and spectators during the event
- Keep track of awards given to teams and display the name of the winner to spectators

It is important to note that many of the features listed are not required to run an event. Many tournament configurations may not use all of the available features, depending on equipment availability, volunteers, and the overall event experience that is desired.

Where to Get Help

If you have questions or are having trouble with the Tournament Manager software, first please make sure you have completely read this User Guide including the Frequently Asked Questions section. If you still have questions or trouble, post in the Tournament Manager section of VEXForum.com or contact your REC Foundation Regional Support Manager.

**Note** - Only Event Partners have access to the Tournament Manager forum on VEXForum.com.
2. Overview and Concepts

While the Tournament Manager software is designed to be as easy to use as possible, an understanding of some of the concepts used by the software is important to get the most benefit from it. In this section, we will review some of the concepts that are used by the Tournament Manager and show how an understanding of these concepts can make the job of running a tournament easier.

Matches and Match Rounds

In a VEX Robotics event, a match is a competition between two alliances on the field where each alliance can be composed of 1 to 3 teams. Matches are typically 1 to 3 minutes in length, and may contain autonomous operation (where software programmed into the robots before the match controls the robot's movement), driver control operation (where 1 or 2 humans control the movement of the robot using joysticks), or a combination of both. Matches are grouped into rounds. The three primary rounds used in a VEX competition are practice, qualification, and elimination.

The practice round is optional and gives teams an opportunity to play a simulated match on the competition field before official competition begins. Practice rounds can be scheduled, with specific teams assigned to specific practice matches, or unscheduled, where the tournament organizers permit teams to come to the field and practice in a match on an ad-hoc basis. If practice matches are scheduled using the Tournament Manager software, then scores can be entered and computed, however the results of the match do not count towards a team's record or rankings.

The qualification round is a set of scheduled matches in which 2 randomly-selected alliances per match face each other. Each alliance is composed of either 1 or 2 randomly-selected teams (depending on how the Tournament Manager is configured). The winner receives 2 win points (WPs) and the value of the loser's score as strength of schedule points (SPs). The loser receives 0 WPs and their own score for SPs. If there is a tie, every team receives 1 WP and their own score for SPs. Teams are ranked based on the sum of their WP scores followed by the sum of their SP scores as a tiebreaker. See the VEX Robotics Competition manual for further details on the rankings process and tiebreakers that are used.

Once the qualification round is complete and the final team rankings are obtained, the elimination round begins. Depending on the event configuration, the top-ranked teams may be able to select partners for the elimination round in an alliance selection process. Alliance selection is described in further detail later on. During the elimination round, alliances are assigned to matches based on their alliance ranking (which is the ranking of the alliance captain at the end of the qualification round). An alliance must win 2 matches against an opposing alliance to advance to the next level of the elimination tournament. The elimination matches continue until a final winning alliance has been determined.
Fields and Field Sets

The Tournament Manager supports the use of 1 or more competition fields on which matches are scheduled and played. While small competitions will likely only need a single field, larger competitions may choose to use more than one field to fit in more matches into the allotted time. If more than one field is being used, then fields can be grouped together into a **field set**. Fields in a single field set share a single **match timer**. The match timer is the clock used to determine how long the match will last and when the robots should be turned off at the end of a match. Because each field set has only 1 match timer, only 1 field within the field set can play a match at a time. The primary use of a field set is when a competition has multiple fields (usually 2 or 3) and wishes to play matches one at a time in a round-robin fashion. This allows time for the field crews to reset a field while the next match is being played on another field.

Each field set has a separate match timer from the other field sets. Therefore, while fields in a single field set can only be used one at a time, fields located in different field sets can play concurrently. This distinction allows for flexibility in running a VEX tournament.

For example, consider an event that has 3 competition fields. One possible arrangement of these 3 fields would be to place them all in a single field set. With this configuration, matches would be scheduled in order on each of the three fields, and only 1 field would be active at a time. If the event started at 10:00am, then match 1 would play on field 1 at 10:00am, match 2 would play on field 2 at 10:05am, match 3 on field 3 at 10:10am, and so on.

An alternate arrangement of these 3 fields, however, would be to place each field in its own field set. For instance, field 1 would be in field set A, field 2 would be in field set B, and field 3 would be in field set C. In this arrangement, matches would be scheduled and played concurrently. If the event started at 10:00am, match 1 would play on field 1 at 10:00am, match 2 would play on field 2 also at 10:00am, and match 3 would play on field 3 on 10:00am as well. All three matches can be run at the same time, and after the matches are complete then matches 4, 5, and 6 would play next.

There are pros and cons to having sequential matches versus concurrent matches. Using 3 fields in a sequential order with one field set allows the spectators to focus on a single match and allows the field crew to be setting or resetting the other 2 fields while the match is playing. Match cycle time can be reduced because the next field should be ready to run as soon as the previous match is complete. Using 3 fields in 3 separate field sets would allow the matches to play concurrently, but the cycle time between matches would need to be increased to allow for the field crews to reset the fields. The event organizer will need to decide which option is most appropriate for the event they are planning.

**Note** - Each field must belong to a field set. If you only have a single field at your event, you will still need one field set for that field.
Audience, Pit, and Field Displays

An important capability of the Tournament Manager program is to provide information that keeps the spectators and team members at the event updated on the event progress and team standings. The Tournament Manager accomplishes this by providing 3 different display programs that can be used. All 3 displays are optional and any combination of the 3 can be used as desired by the event organizers. Further information on how the display programs operate and how they interact with the rest of the Tournament Manager system will be provided later in this document.

The first display program is known as the **Audience Display**. The purpose of the Audience Display is to provide information to the event spectators. Information shown on this display includes the match timer, match score results, alliance selection, and rankings information. Most events that use the Audience Display will show it on a large screen that faces the audience using a projector. Additionally, the Audience Display program generates the game sounds, such as the start-of-match bell and end-of-match buzzer. Typically, the audio output of the Audience Display computer will be connected to the A/V system in the competition venue to allow competitors and spectators to hear the game sounds.

The next display program is known as the **Pit Display**. The primary purpose of the Pit Display is to allow teams to view the current team ranking information. The Pit Display also provides some information on matches that are scheduled to play soon and can also show Alliance Selection information. A typical event will provide at least one Pit Display, often showing on a projector screen or large HDTV or computer monitor. Larger events may wish to use multiple Pit Displays to show the rankings information in convenient areas throughout the competition venue.

The final display program is known as the **Field Queue Display**. The Field Queue Display is meant to be located close to a competition field and shows information specific to that field only. Prior to a match, the Field Queue Display shows which teams are scheduled to compete in the next match on that field, and during a match the Field Queue Display shows the match timer for that field. Events which use the Field Queue Display typically show it on a regular computer monitor located close to the field. A bracket is available to attach a regular LCD computer monitor directly to the field border from VEXRobotics.com.

**Note** - Remember, all 3 display programs are optional. However, most tournaments will want to at least use an Audience Display as this program is where the match timer is displayed and also generates the match sounds.
3. Software Installation and Hardware Setup

Minimum Requirements

The Tournament Manager software requires a PC (desktop or laptop) running Windows 7 or newer or macOS 10.10 or newer. Generally, any PC made within the last 5 years will be acceptable. The computer will need one USB port for each competition field you wish to control (a USB hub may be used if required) and a network connection if you wish to use multiple computers. Additional computers may be used for Audience, Pit, or Field Queue Displays. Additionally, a printer is strongly recommended. If you plan to use a USB printer, make sure there are enough USB ports for the printer, the field control boards, and any other USB accessories you plan to use (such as a USB flash drive). Plan ahead to avoid having to swap USB connections between devices during the tournament.

Tip - If you are using a laptop, you may want to connect an external mouse rather than relying on the laptop's trackpad.

Note - If you are planning to use multiple computers to run your event, the network connections between them should be made with wired Ethernet. Wireless networks can introduce information delays that can disrupt the connection between the Tournament Manager programs and the Tournament Server.

Installation

The Tournament Manager is distributed as a downloadable installer setup program for Windows and a Disk Image (.dmg) for macOS. The latest version of Tournament Manager is always available at vextm.dwabtech.com.

For Windows users, download and open the Setup file. An installation wizard will appear that will guide you through the installation of the program. You should not need to change any of the settings during installation - the default settings provided will work best. In addition to installing the Tournament Manager software, the setup program will also install the hardware drivers for the VEX Field Controller. Follow the on-screen directions and disconnect any field controllers from the computer before proceeding. Once the setup program is complete, click the Finish button to close the wizard.

For macOS users, download and open the Disk Image file after downloading it. The Disk Image will expand and show the Tournament Manager icon and the Applications folder. Drag the Tournament Manager icon into the Applications folder to install it. After that, the Tournament Manager program will be accessible in your Applications folder.

Setting Up the Hardware

After the software is installed, the next step is to set up all of the hardware that will be used during the tournament. If you do not have all of the hardware available, you can skip this section for now and proceed to Starting the Software and Creating a Tournament. However, it is important to obtain all of the hardware that will be used during the tournament, set it up, and test it several days before the event so that you can ensure that everything works and you are familiar with how everything is connected and operated. Return to this section when you have all of the hardware available that will be used.

The hardware setup that your tournament will use depends on what equipment you have available and how large of a tournament you are running. This section will provide examples of some typical configurations to help you get started. It is possible to use configurations other than what is described here. Just make sure that everything
is set up and tested the same way it will be used during the tournament ahead of time so that there is time to deal with unexpected problems.

The minimum amount of equipment required to hold a basic event with one competition field is just a single computer to run the Tournament Manager and one VEXnet Field Controller kit (http://www.vexrobotics.com/275-1401.html). For this basic setup, simply install the Tournament Manager software on the computer and set up the Field Control hardware according to the directions included with the Field Control kit. It is not necessary to install the software and drivers included with the Field Control kit since the drivers necessary are installed automatically as part of the Tournament Manager. If a projector is available you can use it to show an Audience Display. See the section titled Starting the Audience Display Program for details on setting up the computer to use the projector for the Audience Display.

For events with more resources, the Tournament Manager is capable of more sophisticated options. Some typical examples are described next. These are only examples of possible configurations and the specifics can be adjusted based on the resources available and the needs of the event.

**Small Tournament Example with Pit Display**

This example will describe a typical setup for a small tournament with 1 competition field and a Pit Display located in the pit area. This is a typical setup for an event with approximately 12-20 teams. The hardware needed for this example setup is:

- 2 laptops with the Tournament Manager software installed
- Wired networking cables and equipment to connect the laptops together
- An HDTV, large computer monitor, or projector to be used as a rankings display in the pit area and the necessary connectors and cables to connect this to one of the laptops
- A computer projector and screen that will serve as the audience display and the necessary cables and connectors to connect to the other laptop
- One VEXnet Field Controller Kit which contains 1 Match Controller and 2 Driver Interfaces
- A printer to print match schedules and other reports

One of the laptops will be the scorekeeping computer and should be set up on a table located close to the competition field. The other laptop will show the Pit Display so teams can see the current rankings and should be located in the pit area. A network connection will be needed between these two computers. If the computers are located close to each other, it may be possible to get a long Ethernet cord to connect them directly. However, typically the pit area is too far away from the competition field to allow this, and in this case it will be necessary to involve the Information Technology staff of the venue you are using and have them assist you with connecting the computers.

To set up the competition area, start by positioning the scorekeeping laptop and connecting power and network to it. Next, connect the VEXnet Match Controller to the scorekeeping computer using the USB cable that was supplied in your field controller kit. After that, connect the two Driver Interface boards to the match controller using the 50-foot cables that were also supplied in the field controller kit. These cables are long so that the driver interfaces can be located at the side of the competition field where each alliance’s drivers will stand. The driver interfaces should be attached to the competition field using bolts or zip-ties and the 50-foot cables and any other...
exposed cables should be taped to the floor to prevent tripping. Next, set up the projector and connect it to the scorekeeping laptop. Finally, connect the printer to the laptop and ensure that it is operating correctly.

To set up the pit area, position the pit display laptop and HDTV or monitor on a table located close to the team pit area. Connect power to the monitor or HDTV and power and network to the laptop. Connect the laptop to the monitor or HDTV.
Medium Tournament Example

This example will go through the setup of a typical medium-sized tournament with 2 competition fields and an additional field for Skills Challenge matches. This setup is typical of events hosting 20-40 teams. The hardware needed for this example setup is:

- Everything listed in the Small Tournament Example PLUS
- 1 additional laptop with the Tournament Manager installed
- 2 additional Field Controller Kits
- An additional HDTV or computer monitor to serve as the audience display for the Skills Challenge field

Begin by following the setup instructions for the Small Tournament Example. After the equipment for the small tournament is set up, the remaining setup tasks will be to add a second field to the primary scorekeeping computer and add a secondary scorekeeping computer that will be used at the Skills Challenge field.

Adding the second competition field to the primary scorekeeping computer is similar to the first. Connect the match controller for the second field to another available USB port on the computer, then connect the driver interfaces to the match controller. Secure the driver interfaces with zip-ties or bolts and tape down the 50-foot cables and any other wires which run across the floor.

Next, set up the Skills Challenge competition area. This area will use another laptop to control the Skills Challenge field as well as enter Skills Challenge scores. This laptop should be connected to the same network as the primary scorekeeping computer and pit display computer. The field control hardware should be set up following the directions in the Small Tournament Example. Since the Skills Challenge matches only have a single team on the field at a time, it is possible to use only a single driver interface. However, teams may wish to operate from their choice of driver station so you might choose to connect both driver interfaces anyway. In this example, the Skills Challenge area will also have an audience display which will be shown on a projector, HDTV, or computer monitor. The primary purpose of this display will be so that teams competing can see the match timer and hear the match sounds (if speakers are connected to the computer). Also, in between Skills Challenge matches, the Skills Challenge scorekeeper may wish to show the Skills Challenge rankings on this display as well to allow teams to see their current standing.
Network Setup

If you plan to use multiple computers as part of your Tournament Manager configuration, you will need to connect them with a network. For best results, the network connection between your Tournament Manager computers should be wired with Ethernet. Wireless networks, while easier to initially set up, can present problems with lost connections or timer delays due to interference or weak signals. For these reasons, the Tournament Manager is officially supported and tested only on Ethernet networks. Use on a wireless network is not officially supported.

If your venue has a built-in network with network jacks in appropriate locations, then this will likely be the easiest method to connect the computers together. Check with the venue for details on how to connect to the network. If a built-in network is not available, you will have to create your own network. The easiest method is to use a wireless router designed for home use. Find one that contains a built-in 4 or 5 port switch. If you plan to use Tournament Manager Mobile (TM Mobile) on phones or tablets, you will need a wireless router that supports the 5GHz radio frequency, so plan ahead. Connecting your computers with this type of wireless router will automatically provide IP addresses for your computers. Make sure to disable the wireless function (except 5GHz if using TM Mobile - see the TM Mobile User Guide for more details) if you are using only Ethernet. Connect the Tournament Manager computers to the ports labeled Ethernet or LAN.

If you have no choice but to use a wireless network for your Tournament Manager configuration, you should consider the following suggestions:

- Make sure all computers on the wireless network have a strong wireless signal. Weak signals will cause delays and lost connections.
- Make sure the channel used for your wireless network does not conflict with other networks in your venue or with the VEXnet robots themselves. Use a tool like the free inSSIDer (http://www.metageek.net/products/inssider/) to scan your venue to see which channel you can use with the least amount of interference.
- If your equipment supports it, use 5GHz or 802.11a which operates on a different set of frequencies than standard 2.4GHz 802.11b/g/n WiFi.
- Do not use the wireless network for anything other than the Tournament Manager. Web browsing and allowing team access should be avoided or provided using a separate network. Enable the password on your wireless access point(s) to prevent others from connecting to the network.
- Do not allow teams to operate their own wireless access points (this is always recommended for competitions using VEXnet robots).
- Ask spectators and competitors to turn off the WiFi features of their phones and laptops and any hotspots (this is also always recommended for competitions using VEXnet robots).
- Avoid using wireless connections for Tournament Manager displays which show a timer on-screen (the Audience Display and Field Queue Displays) as interference or delays will be most visible when a timer is running.

**Note** - The Tournament Manager programs are designed to reconnect automatically if the network is disrupted. If you are running display programs over a wireless network and there is disruption due to interference, you may see a dialog indicating that the Tournament Manager is reconnecting. If the connection is broken, it will be detected within 1-2 minutes and reconnect automatically.
4. Creating a Tournament

After installation, you can start the Tournament Manager software by clicking on the Tournament Manager icon in the Windows Start menu or the macOS Applications folder. When you first start up the Tournament Manager, you will see the window shown in Fig. 4-1. In this window you have 3 options. The first two options will open a tournament data file on your computer and start the Tournament Server with this data file. The third option in the window will connect to a Tournament Server that is already running on another computer. Information on how to use this feature will be covered later on. Choose Create a new tournament and enter a new filename which will be used to save your new tournament.

After you finish entering the filename for your tournament, the Tournament Server will start. This can take a few seconds while the tournament data file is created. During this time, you will see the window shown in Fig. 4-2. After a few seconds, this window will disappear and the Tournament Manager will start.

If the tournament data file you selected has not been used before, then the next window you will see will be the Tournament Setup Wizard (Fig. 4-3). The Tournament Setup Wizard will guide you through the process of configuring your tournament. While completing the wizard, you will have the opportunity to specify which teams will be competing, to schedule practice and qualification matches, and to set up fields and field sets.

Tip - If you decide to change settings later on, you can re-run the Setup Wizard at any time. Also, most options can be adjusted by selecting Tools ⇒ Options from the Main Window.

Note - Some of the wizard pages may not apply to the particular VEX competition (VEX IQ, VRC, or VEX U) you're running and will be omitted from the wizard.
To begin using the Setup Wizard, click **Next** at the Welcome screen. The first choice you will be presented with is to select which type of tournament you are setting up (Fig. 4-4). Select the type that most closely matches your tournament and press **Next** to continue. The choice made here will determine which settings are available later on. The rest of this section will assume that **Small Tournament** was chosen. Details of the settings available for other choices will be covered later on.
General Settings Page

The next Setup Wizard page will ask you for the name of your event. The name should be a short description of your event and will be used on printed reports and some Audience Display screens. An example event name might be "Northern Illinois VEX Challenge". The event name should be kept short (4-5 words is appropriate).

In addition to the event name, you will be asked to provide a password for the Tournament Manager. This password will be used when connecting to the Tournament Server from remote computers (it will not be used when you connect to the Tournament Server running on the same computer). It is important to set this password so that unauthorized users cannot connect to your Tournament Server and modify scores or otherwise interfere with your event. You can use the Create Random Password button to generate a random 5-digit password for you if you wish. The Setup Wizard will require you to set a password before you can continue. Once an event name and password are entered, click Next.

The final section on this page allows you to specify the Event Code and TM Code for your event (if your event is an official event listed on RobotEvents.com). Go to your Event Administration page on RobotEvents.com to find this information. You will need to fill in this information on this page to take advantage of some features in Tournament Manager later on.

Game Scoring Configuration Page

The Game Scoring Configuration page is next. This page allows you to choose what type of game will be played at your event. The configuration specifies which VEX program (VEX IQ, VRC, VEX U) you’re running, what types of points can be scored in a game, how match scores are calculated, and how long each match should last. The Tournament Manager software comes pre-loaded with several game configurations. Be aware that there may be alternate game files for some competition variations (such as VEX U).

Team Setup Page

Next is the Team Setup page. There are three options for adding a team list to the Tournament Manager. The first option allows you to download the team list automatically from RobotEvents.com. To use this option you must configure the Event Code and TM Code on the General Settings page. The second option allows you to import a list of teams from a specially-formatted .CSV file. This .CSV file can be created using Microsoft Excel, and a blank file is available for you to fill in (located in the Tournament Manager folder under the Start menu). The last option is Simply choose number of teams. If you select this option, the next wizard page will ask you to provide the number of teams. Teams will be created starting with team number 1. This option is useful for unofficial events where the event organizer does not wish to spend time creating a custom list of team names.
and numbers.

**Elimination Tournament Setup Page**

The Elimination Tournament Setup page (*Fig. 4-6*) controls how your elimination round will be played. The *Elimination alliances* setting indicates how many alliance captains will be given the opportunity to participate in Alliance Selection. The *Teams per elimination alliance* setting controls how many teams will participate in each alliance. This number can be larger than the number of teams who compete on a field at the same time, and in this case the alliance captain will pick from within their alliance which teams will compete in each elimination match.

The *Unbalanced Alliances* setting deserves special attention. This setting is important if the number of teams at the tournament is less than the number of spots in the tournament. The number of tournament spots is the *Elimination alliances* setting multiplied by the *Teams per elimination alliance* setting. This commonly happens at smaller tournaments where the event organizer wishes to allow all teams in attendance to participate in the elimination round, rather than lowering the number of elimination alliances and leaving a few teams sitting out from the elimination tournament. By default, this setting is set to "Don't allow unbalanced alliances". In this case, if there are more tournament spots than eligible teams, it will not be possible to start Alliance Selection. The other option will allow Alliance Selection to start in this case and will leave some alliances with fewer teams than the *Teams per elimination alliance* setting specifies.

The *Fill unbalanced alliances starting with the high seeds* option allows the higher-ranked alliance captains to

---

*Figure 4-6 - Setup Wizard elimination tournament setup*
select additional alliance members from the remaining teams, while lower-ranked alliances will be left with fewer teams than the \textit{Teams per elimination alliance} setting. With this setting, a normal alliance selection order is followed until there are no further remaining teams, at which point Alliance Selection is complete.

The last setting on the Elimination Tournament Setup page is \textit{Alliance selection audience display}. During alliance selection, a list of teams that are available to be selected by alliance captains is shown on the Audience Display. Some events prefer to show this list sorted by team number while other events wish to show the list sorted by rank. Sorting by team number makes it easier for alliance captains to quickly look at the list and determine if the team they wish to choose is still available while sorting by rank allows alliance captains to more easily select a highly-ranked team if they do not already know who to pick. Often, this setting will be chosen based on the average experience level of the teams who will be attending the event. If the teams who will be attending are generally new and inexperienced, it is likely they will not prepare their own list of teams to select, and having the available teams sorted by rank will allow them to more easily select a good partner. If the event will have primarily experienced teams, they are more likely to know which partners they want and will prefer to see the available teams sorted by team number. Ultimately, the event organizer should make the determination of which setting is most appropriate.

\textbf{Field Set Page}

When using the \textit{Small Tournament} settings, the Field Set page will already be filled in with appropriate values. A field set named "Field Control" is already provided, with a single field simply named "Field". If you wish, you may change the name of the field set or the field, however this is not necessary. Click Next to accept the settings and move on.

\textbf{Skills Challenge Fields Page}

Next is the Skills Challenge Fields screen. On this screen you are asked to specify the number of fields that will be controlled using a field controller kit and will be dedicated to Skills Challenge matches. Unless you have an additional field and field controller kit in addition to your competition field, you can leave this setting at 0 and click Next.

\textbf{Pit Display Page}

The Pit Display Setup is next. You can have multiple named Pit Displays and control them separately from the Tournament Manager. Small events typically only have 1 Pit Display, so you can simply click Next at this screen.
Note - If all teams have not checked in, a section will appear at the top that allows you to select whether the schedule is generated with all of the teams or only the teams that have checked in.

The Schedule Setup page appears next (Fig. 4-7). This screen is where you configure your tournament schedule. The tournament schedule is created by adding blocks of time known as **Schedule Blocks**. A schedule block is a period of time during which either practice or qualification matches will be scheduled. Multiple blocks for each type of match can be created and blocks can be created on different days as well. Additionally, each schedule block has a **Match Cycle Time** setting. The Match Cycle Time indicates how frequently matches will be scheduled. A setting of 5 minutes, 0 seconds means that a new match will begin every 5 minutes (it does not mean that there will be 5 minutes after the end of one match before the start of the next).

Tip - Setting the match cycle time correctly is important to holding a successful event. If you are not sure what cycle time to use, talk to other event organizers to find out what worked for them. Many smaller events use a 6 minute, 0 second cycle time with success, but might have difficulty with faster cycle times. Be sure to plan some buffer time into your schedule for unexpected problems to avoid having an event that lasts late into the night!

Schedule Blocks allow for a lot of flexibility. For example, many tournaments have difficulty at first staying on
schedule as volunteers and teams adjust to the flow of the competition. A good use of schedule blocks in this case is to configure a block for the first few hours of an event with a longer match cycle time, and then have subsequent blocks move to shorter cycle times. An event that plans to hold qualification matches from 9:00am to 5pm on Friday might have 3 schedule blocks. The first block would be from 9:00am to 12:00pm and would have 6 minute match cycle time. The next block would be from 1:00pm-3:00pm and would have 5 minute, 30 second cycle time. Finally, the day would finish with a block from 3:00pm-5:00pm with a cycle time of 5 minutes.

**Tip** - To create a lunch break, schedule a morning block that ends at the beginning of your lunch period and an afternoon block that begins when the lunch period should end.

On the lower half of the Schedule Setup screen is a list of blocks that have already been created. At the right side of each block is a **Max # Matches** number. This number is the maximum number of matches that can be scheduled in that block using the cycle time specified. When practice and qualification matches are created, the Tournament Manager ensures that each team plays an equal number of matches without exceeding the total amount of time available from the schedule blocks. If adding an additional match for each team would exceed the available time, then those matches are not added and the remaining matches that are created may not use up all available time. You may need to adjust your schedule blocks slightly to ensure enough time is scheduled to accommodate the desired number of matches per team.

**Note** - Schedule blocks are created for practice and qualification matches only. Blocks do not need to be created for the elimination round - instead, make sure that your last qualification block end time is before your elimination round should start. Don't forget to budget time for Alliance Selection, which must happen before the elimination round can begin. Alliance Selection typically takes 15-25 minutes.

### Create Matches Page

The Create Matches page contains two buttons, **Create Practice Matches** and **Create Qualification Matches**. These buttons cause the Tournament Manager to begin computing a match schedule for the teams for the practice and qualification rounds respectively. Creating practice or qualification match schedules is a complicated process that attempts to find a balance between teams playing in matches with different partners and opponents as much as possible and not having the same team play in 2 different matches that are too close together, leaving little time for repairs from the previous match. Click each button to generate the match schedule for that particular round. Generating the match schedules may take several minutes depending on how many matches there are and the speed of your computer. After matches are generated, the number below each button will tell you how many matches were actually created.

**Note** - If either button is grayed out, it indicates that there were no schedule blocks available for that match type. Use the **Back** button to go back to the Schedule Setup page if your schedule setup is not correct.

### Awards Setup Page

The Awards Setup page contains a list of tournament awards that may be given out. Each award can be a Team, School/Club, or Individual award. Awards are assigned to teams, clubs, or individuals later on - this page is only used to specify which awards will be available to give out at your event. The awards page is pre-filled with typical awards given at VEX Robotics events. If you wish to add a custom award you can do so by filling in the award name and choosing whether it will be given to a Team, School/Club, or Individual and clicking **Add Award**. Awards with checked boxes will be available at your event, while awards with boxes left unchecked will not be available.
Tip - It is not necessary to remove awards that you do not plan to use. However, it may reduce confusion later on when award winners are assigned.

Web Publishing Setup Page

The Web Publishing feature allows results of your event to be posted online in real time as the event progresses to the event page on RobotEvents.com as well as the VEX via mobile app for Android and iOS.

In order to publish results online, the event must be listed on RobotEvents.com and the relevant information must be filled in on the General Setup page. You can select which types of results are published to RobotEvents.com during your event as well as which divisions. If you are only using one division or you are unsure of what to select, leave this set to "All Divisions". The Division ID field is not normally needed. Do not enter anything in this field unless you've been instructed to do so.

Publishing will happen automatically as data is updated in Tournament Manager. You can also choose to manually publish some data using the buttons on the Web Publishing page. For example, you might choose to manually publish the match list after it has been generated but before your tournament is starting.

Tip - Enable publishing and encourage your event's teams to use the VEX via app to keep track of their match schedule and rankings. Allowing teams to have updated information on their mobile devices will often be helpful in keeping your event on schedule.
Setup Wizard Complete

At this point the Setup Wizard is complete. Click Finish to close the Wizard and open the Tournament Manager Main Window. If you wish to re-run the Setup Wizard later on, you can do so by choosing Tools ⇒ Run Wizard from the Main Window menu. However, this will clear out the results of any saved matches. If you wish to modify settings without clearing match results, the appropriate way to do so is by accessing the Options page by selecting Tools ⇒ Options from the Main Window menu.

Connecting the Match Controllers to Tournament Manager

After you complete the Setup Wizard, you will be presented with the VEX Tournament Manager Main Window. Additionally, if you have one match controllers connected to the computer, the Set Up Field Controllers window (Fig. 4-8) will appear. Details of the Main Window and running an event are located in Chapter 5 - Running An Event. If you do not have any match controllers connected, you can skip ahead to that section.

The Field Controllers Setup Window shows a list of match controllers that are connected to the computer. For each match controller found, you must choose the field set and field that it belongs to. For example, in the Medium Tournament Example discussed previously, there are 3 total fields. Field Set 1 would contain Field 1 and Field 2 which are the competition fields. Field Set 2 would contain Field 3 which is the Skills Challenge field. When starting up the primary scorekeeping computer from the Medium Example, 2 fields should be listed in the Field Controller Setup Window. These two fields should be assigned to Field 1 and Field 2. When the Skills Challenge scorekeeping computer is started, one field will be shown and it should be assigned to Field 3.

Tip - When more than 1 match controller is connected to the same computer, make sure that the correct field number is assigned to the appropriate match controller. The Test buttons next to each match controller in the Field Controllers Setup Window will enable the respective field in the appropriate mode, either driver or autonomous. You can look at the Driver indicator light on the driver interface - it will turn green when the field is enabled.

After you have finished setting up the field controllers, the Field Control tray icon (Fig. 4-9) will be visible in the computer’s system tray.
**Starting the Audience Display Program**

The Audience Display program shows important information to your audience during the event. Although the Audience Display is not required to run an event, using it makes your event appear more professional and allows the audience and teams to be more engaged.

Before starting the Audience Display program, you should set up the display properties for the computer on which the Audience Display program will run. Most events choose to run the Audience Display on the same laptop as the Tournament Manager. To make the best use of the Audience Display program, you need a computer that can output a different image through the monitor port than what is shown on the computer's built-in screen. This is called *multiple monitor support*. Windows users can enable this feature by connecting multiple monitors, then holding down the Windows key and pressing the P key, then choosing the Extend option. Users with macOS should select the Displays option under System Preferences and uncheck "Mirror Displays" under Arrangement. Additionally, "Displays have separate Spaces" should be unchecked in Mission Control to prevent the menu bar from appearing on the audience display. If you only have one monitor to use for both scoring and audience display (for example, at a skills challenge field), you can use the *Fullscreen During Timer Only* option under the *View* menu which will display the match timer full-screen only while the timer is active, allowing you to enter scores in between.

---

**Tip** - If you need to adjust the field controller setup or test the field control boards, you can right-click (Windows) or click (macOS) on the Field Control tray icon and select the *Reconfigure* menu option to access the Set Up Field Controllers window at any time. Note that entering the Field Controllers setup window will interrupt any matches in progress so do not choose the *Reconfigure* option while a match is being played.
The Audience Display can be started from within Tournament Manager under the *Displays* menu. Additionally, on Windows, shortcuts can be found to start audience displays in the Tournament Manager folder in the Start menu.

When the Audience Display is first started, it will be showing in a window. The *View* menu at the top of the display window can be used to set the Audience Display to show full-screen on any of the connected displays. The *Identify Monitors* menu item can be used to determine the display number for each monitor.

Once you set a Display to be shown full-screen, a Preview window will appear. This is useful in case you cannot see the full display (such as if it is connected to a projector that is facing away from the scorekeeper). The preview window shows a snapshot of what is being seen on the full-screen display. The preview window may be resized or closed as desired.

### Starting the Pit Display Program

The Pit Display program provides valuable information to teams during the event. Typically the Pit Display is shown on a projector or large TV or monitor in your venue’s pit area. The Pit Display program usually runs on a different computer than the one used for scorekeeping. In this configuration, the Pit Display computer needs to be connected to the scorekeeping computer by a wired network connection. Install the Tournament Manager software on the pit display computer as described in the Installation section above.

The Pit Display operates similarly to the Audience Display program discussed above. If the Pit Display is running on a standalone computer, select *Fullscreen on Monitor 1* from the *View* menu to make it fill the whole screen.

When you start any of the Display programs on a computer other than the main scorekeeping computer, you will see the *Connect to the Tournament Server* window (Fig. 4-11). In this window, you will need to enter the IP address of the main scorekeeping computer and the Tournament Manager password that you set in the Tournament Setup Wizard. If you forgot the password, you can view it by selecting *Tools ⇒ Options* in the Tournament Manager window and selecting the *General* category. After you enter the correct IP address and password and click *Connect*, the Pit Display will start. You can change what is shown on the Pit Display by selecting the *Pit* menu in the Tournament Manager.
5. Running An Event

Main Window

Once the Setup Wizard is complete and any match controllers are assigned with the Set Up Field Controllers window, you will be left with the Tournament Manager Main Window (Fig.). The Main Window has a standard menu bar, a series of tabbed pages filling the majority of the window, and a status bar at the bottom.

Note - Some of the features in this section may not apply to the VEX Robotics program (VEX IQ, VRC, VEX U) you are running; the tabs, buttons, and menu items may be hidden depending on the game configuration selected in the wizard.

Before The Beginning of the Event

Before the event starts, you will want to run the Setup Wizard, setting up the team list and scheduling practice matches (if you plan to run scheduled practice matches). Many events do not schedule the qualification matches until after team check in so that teams who do not show up can be removed from the team list. After importing the team list and scheduling practice and/or qualification matches, you should make printouts of the match lists for attending teams. Under the Reports ⇒ Match Lists menu, you can print practice and qualification match lists. Additionally, an option is available to print a qualification match schedule sorted by team number. This may be useful to judges or other volunteers to allow them to easily determine when a particular team will be competing.
Running Practice and Qualification Matches

Once the event begins, the primary job of the scorekeeper is to run and score practice and qualification matches. Matches are run by opening the field set window. To open the field set window, select the Field Sets menu followed by the name of the field set you wish to control. The field set window (Fig.) will appear.

The field set window provides the ability to control the robots on the field as well as controlling what is shown on the Audience Display. The Match On Field box indicates which match number is ready to be played and is controlled by the Scoring tab. The Saved Match box indicates the match that will be displayed on the Audience Display when Saved Match Results is selected, and is typically the last match that played on the field. Match Timer shows how much time is remaining in the match.

Beneath the Match Timer box are the Start Match, Reset Timer and End Early buttons. Start Match will enable the robots on the field, start the match timer, and play the start of match sound through the Audience Display (and optionally the scoring computer if Play Sounds is checked in the field set window). While a match is running, the Reset Timer button changes to Abort Match. Pressing Abort Match will stop the match timer, disable the robots, and play the aborted match sound through the Audience Display. Also while a match is running, the End Early button is enabled. This button ends the current match segment early as if the timer had expired. After a match ends, either normally or by being aborted, Abort Match will change to Reset Timer. Reset Timer will reset the match timer to prepare for the next match. The Field box indicates which field within the field set will be controlled. The Set Timer button inside the Time-out box allows the scorekeeper to use the match timer to keep track of a timeout called by a team on the field. When the match timer is set to the timeout value, the Match On Field box will say "TO" to indicate a timeout. The Start Match button can be used to start the timeout timer (robots on the field will not be enabled during a timeout).

Tip - A common use of the End Early button is to stop autonomous mode early. This is frequently used in VEX U where the autonomous period can be quite long. If the Head Referee determines that all robots have completed their autonomous routines, the scorekeeper can use the End Early button to stop autonomous and pause the match. Then, use the Resume Match button as normal to continue with the driver control portion of the match.

On the lower left side of the field set window is the Autonomous Winner box. Use this box during a match to indicate on the Audience Display which alliance won the autonomous mode. If you are playing a game that does not have an autonomous mode or neither alliance wins the autonomous mode, then just leave this set to None. The Autonomous Winner will be reset to None whenever a new match is queued to the field set.

Note - The Autonomous Winner box does not directly affect the score of the match. It is intended primarily to alert the audience to the autonomous winner while the match is still in progress. However, as a convenience, if the Match On Field is the same match that is selected in the scoring input window, then when the autonomous winner is changed in the field set window the scoring input window will be updated accordingly. If a different match is selected in the scoring input window then no changes will be made.

On the right side of the field set window is the Audience Display box. You can control which screen is shown
on the Audience Display by changing the selection in this box. The *Intro* and *In-Match* screens will show information for the match listed in the Match On Field box, and the *Saved Match Results* screen will show information for the match in the Saved Match box. Other screen choices allow you to show the current rankings, alliance selection, elimination bracket, and other information. The screen can be set to *None* or *Logo* during periods of downtime, such as in between matches. Teams often appreciate it when the rankings screen is shown during longer breaks such as during lunch.

![Figure - Scoring Input tab](image)

In addition to the field set window, the Scoring tab in the Main Window (*Fig.*) is used while running practice and qualification matches. After the referees finish scoring a match, the scorekeeper will enter the scores into the Scoring tab and click the *Save Scores* button. This will save the scores into the tournament data file and update the rankings (if the match being scored is a qualification match).

When match scores are entered into the Scoring tab, the Tournament Manager checks the scores against the known limits of the game. If the score entered is not possible for a particular game (for example, more game pieces are scored than are available in the rules), the Tournament Manager will display a warning and highlight the score values that are out of range. If this happens, the scorekeeper should check with the Head Referee to ensure the entered scores are correct.

When Tournament Manager starts up, it does not check the scores of all previously saved matches; it checks each match score when it is selected from the Match List Tree. Select *Tools ⇒ Check for Illegal Match Scores* to prompt Tournament Manager to check all match scores.

**Note** - Even if the Tournament Manager detects an out-of-range score, it will still allow the match to be saved. This is in case the game is being played with modified rules or if there is some other reason that the event organizer has allowed scoring beyond the official game limits.
Located on the left side of the Scoring tab is the **Match List Tree**, organized with the practice, qualification, and elimination rounds listed as the primary categories. Clicking on the + next to any category will expand it to show the list of matches available under that category. With the match list expanded, you can click on any match to select it for entering scores on the right side of the Scoring tab. Additionally, the Match List Tree is where the scorekeeper can control which matches are currently in the **Match On Field** and **Saved Match** boxes in the Field Set window. To accomplish this, right-click on any match listed to bring up the **Queue Match** menu. From this menu, you can choose to queue the match on one of the available field sets which will place the selected match into the **Match On Field** box. If the match score for the selected match has already been saved, you can also choose to send the match to the **Saved Match** box on the field set window in order to show the results of the match on the Audience Display.

At the top of the match list tree is a special match called **Field Test Match**. This match can be queued to a field set just like a normal match for practice or testing the field equipment. When queued, the Field Set window will show "P0" as the **Match On Field**. It is important to queue this match for ad-hoc practice matches or field testing rather than using an upcoming scheduled match. If a scheduled match is used for field testing (for example, during a lunch break), the Pit Display will update the match times displayed to teams, which could lead to confusion. Times will not be updated when the Field Test Match is used.

The state of each match is shown by the icon in the Match List Tree:

- ![Match is unsaved](image)
- ![Match is unsaved and modified](image)
- ![Match is submitted by referee using TM Mobile, but not yet saved](image)
- ![Match is submitted by referee using TM Mobile, but not yet saved and was modified locally](image)
- ![Match is saved](image)
- ![Match is saved and has changes that were not yet saved](image)
- ![Match is saved with a score that is out of range](image)

**Tip** - When you save a match score using the **Save Scores** button and the match you are saving is one of the last 2 matches that were in the **Match On Field** box, then the match just saved will be automatically placed in the **Saved Match** box on the field set window. This saves time during typical usage where the match results are shown either immediately after the match is played or after the subsequent match is played.
Running Skills Challenge Matches

Skills challenges are an optional component of some robotics competitions. Skills challenges allow teams to compete on a field by themselves to show what their own robot is capable of without interaction from opponents or alliance partners. The Tournament Manager supports two types of skills challenges, Driver Skills and Programming Skills. Driver Skills is a driver-controlled event while Programming Skills allows only autonomous control of the robots.

To access the skills challenge feature, select the Skills Challenge tab in the Main Window (Fig.). On the left side is a tabbed list of previously entered scores for each skills type, and on the right side is where scores are entered.

On the lower right side of the window is the Field Set area. This area allows you to queue a skills challenge match on a Field Set and to display scores on the Audience Display. Select the Field Set you wish to use in the dropdown and then click Queue on Field. This will send the skills match to the appropriate Field Set window (see Fig.). Once the match is queued on the Field Set, the match can be run in the same way that regular matches are (see the Running Practice and Qualification Matches section for more details). Once the team has completed the skills match, select the team in the Team Number dropdown and enter the score details in the Score area and click Add Driver Skills Score or Add Programming Skills Score. The score will be added to the list on the left. To edit an existing score, right click on it in the scores list, select Edit Score, modify the score details, and save the score. To delete an existing score, right click on it in the scores list and select Remove Score. Additionally, the skills scores can be shown on either the Pit or Audience Displays by selecting SC Rankings in the display control area.

Note - Queuing and running a Programming Skills match will cause the robot to run in autonomous mode only, while queuing and running a Driver Skills match will cause the robot to run in driver-control mode only. Make sure that you are queuing the correct match type for the skills challenge that the team wishes to compete in.
Alliance Selection

Once the qualification matches are complete, the next task is to proceed with Alliance Selection, if the game configuration calls for an Elimination Tournament. Alliance Selection is the process of allowing the top qualifying teams at the tournament to select alliance partners to compete with them during the elimination round. Before beginning Alliance Selection, the field set window should be used to change the Audience Display to the Alliance Selection option. To proceed with Alliance Selection, select the Alliance Selection tab in the Main Window. Initially, the Alliance Selection tab will be mostly empty, with two buttons located in the middle of the screen. Start Alliance Selection will lock all of the qualification matches to prevent changes and obtain the most current rankings to fill in the available teams box on the left side of the window. The Start Alliance Selection (Manual) is very similar, with the only difference being that the Manual mode allows the scorekeeper to select alliance members in any order.

![Alliance Selection tab](image)

Once Alliance Selection is started, the contents of the tab will change and new buttons will be available (Fig.). When a picking team selects a partner, the scorekeeper should highlight the correct team in the Available Teams box and click the Add Team button. A popup window will appear asking whether the selected team chose to Accept or Decline. The Accept button will add the selected team to the alliance while the Decline button marks the team as declined. When a team declines, they are still eligible to be an alliance captain if they are seeded high enough but they cannot be selected by another alliance captain. The team will appear in a lighter color in the available teams list to indicate this.

As Alliance Selection continues, the scorekeeper will continue to record the selections made by the alliance captains until all alliances are filled. Once all selections are made, everything should be double-checked for accuracy before clicking the Finalize Alliances button. Finalize Alliances will lock in the alliance selections and create the first round of elimination matches which will be visible under the Elimination tree in the Scoring.
Running Elimination Matches

After Alliance Selection has been performed, it will be time to run the elimination matches, if the game configuration calls for them. Elimination matches are operated much like the qualification and practice matches. One difference during elimination matches is that the matches will not appear in the Match List Tree until the alliances that will compete in the match are known. This means that after Alliance Selection is finished, the only matches that will appear initially are the Quarter Final matches. Each time an elimination match is scored, the Tournament Manager checks the elimination ladder and determines if any new matches can be created. An alliance must win 2 matches in each round to advance to the next round, and the Tournament Manager will continue to add matches in the current round until one alliance has won at least 2 matches.

**Tip** - If you have more than 1 field in the field set that you are using for elimination matches, make sure to select the correct field in the field set window before starting each match. The Tournament Manager does not know which field you plan to run each elimination match on, so it cannot change the Field dropdown automatically for you like it did during the qualification matches.

After one alliance wins two matches in the Final round, the tournament will be complete. If there are awards to be given out, then the scorekeeper will need to use the Awards tab to perform this task, otherwise the scorekeeper's job for the tournament is nearly complete. Scorekeepers should check with the event organizers and other volunteers to find out if any printouts of results are desired before shutting down the computer. Final rankings, match results, awards, and other reports can be printed from the Reports menu.

In addition to printed reports, the results of the tournament can be saved to a spreadsheet using the *Export* menu. Team information, rankings, match results, award information, and skills challenge results can be saved to individual .CSV files which can be opened by nearly any spreadsheet program. Additionally, all of this information can be saved into an Office Open XML Workbook format (.xlsx file) which can be opened by Microsoft Office 2007 or OpenOffice.
Running Finals Matches

Some game configurations call for alliances of the top teams to be automatically paired with one another and then each alliance plays a single Finals match to determine the winning alliance. After the qualification matches are complete, you must create the Finals matches by selecting the Matches ⇒ Create Finals Matches menu option. This will create the new Finals matches in the Finals folder in the Scoring tab. Run through the matches just as you did the Qualification matches, queuing them to fields and displaying the results on the displays. After all the Finals matches are played, look at the Rankings tab for the final standings.

Tip - A dropdown at the top of the Rankings tab will allow you to select between Qualification Rankings and Finals Rankings.

Assigning Award winners

Most events will present awards to participating teams once the elimination tournament or finals matches are complete. The Tournament Manager provides the ability for tournament organizers to set up a list of awards which will be presented and to assign winning teams, individuals, or clubs to those awards. Additionally, award winner information can be shown on the Audience Display for a more professional look.

The list of awards which will be presented at your event are set during the Tournament Setup Wizard and can also be accessed using the Tools ⇒ Options menu and selecting Awards on the left side of the Options window. Details of setting up the awards list are provided in Section 3, Software Installation and Initial Setup.

Figure - Awards tab

To assign award winners, select the Awards tab from the Tournament Manager Main Window (Fig.). Then, select the award you wish to assign by clicking on the award name in the list on the left side of the window. Next, choose the Team Number of the winning team or fill in the Name of the award winner in the area on the right.
(either Team Number or Name will be grayed out depending on what type of award you have selected). Finally, click the Save button to save the award winner information.
Displaying Award Winners & Other Slides

If you wish to show slides of the award winners on the Audience Display when the awards are presented, start by selecting the Slides tab. For a simple slide show that only displays the winners of each award one at a time, click the "Auto Add Slides" button. Select the appropriate options from the pop-up window and click the "Create Slides" button. This adds two slides for each award, an Intro slide and a Single Award slide (see below for the description of each slide type). After the list in the bottom-left quadrant of the window is populated with the award slides, select a slide; a preview is shown in the upper-left quadrant. Either double click the slide in the list or click the "Send Preview to Live" button to show the slide on the Audience Display. The Auto-Add functionality is enough for most events, but some may want to take advantage of the other slides that are available. Below is a brief description of each slide type:

- **Intro** - Shows just the name of the award; it is commonly used while the announcer reads a description of the award before the winner is announced.
- **Single Award** - Shows the name of the award and the winner's name along with team number and location if the award is a team award.
- **Single Award Mult Div** - Shows the winners of a single award type for each division that is configured for the slide.
- **Mult Awards Single Div** - Shows the winners of each award that is configured for the slide.
- **Elim Alliance** - Shows the number and name for all the teams in the configured alliance.
- **Speaker** - Shows the name, title, and company of a person; it is typically used when someone is speaking before presenting an award.
- **Multi Speaker** - Shows the name, title, and company of up to two people.
Finishing The Event

Once the event is complete, you should upload the results of the event to RobotEvents.com. Your event must be listed on RobotEvents.com to do this, and you must have filled in the Event Code and TM Code in the General settings panel (use Tools ⇒ Options if you need to fill in these values). During this process, results are sent to VEX for tracking results and displaying event information on the Internet. VRC, VEX IQ, and VEX U events will also use this information for qualifying teams for the World Championship and other events that require qualification.

To upload your event results, select the File ⇒ Upload Results to RobotEvents.com menu option. The Upload Event Results window will appear. In this window you can select the types of results that you wish to upload and also whether to finalize the results. Once the results are finalized, the award winners will appear on the event page at RobotEvents.com and you will no longer be able to upload results from the Tournament Manager. If you accidentally finalize the event, you can revert this on the event administration page at RobotEvents.com.

Once your information is entered, click on Upload Now. As a reminder, when the Tournament Manager is shut down after the elimination round is complete, the user is prompted to upload the event results. If the venue doesn't have Internet access, the results can be uploaded later when the Tournament File is opened on a computer with Internet access.

Important Note!
When you upload results to RobotEvents.com, your team list and award list is checked against the information on RobotEvents.com. If you have added teams to your event, they must be added at RobotEvents.com before you are allowed to upload. Also, if you have given out awards that are not listed on RobotEvents.com, you will need to add them to your event at RobotEvents.com before you can upload the award winners.
Shutting Down the Software

Once the event is complete and the Tournament Manager and the Audience, Pit, and Field Queue Displays are no longer needed, you may shut down the software. To properly shut down the software, close the Main Window. When prompted, choose the option to shut down all Tournament Manager programs, and all other programs (such as displays) will close automatically.

**Tip** - If the Main Window is running on the same machine as the Tournament Server, then when it is closed you will be given the option to shut down all tournament applications. Select **Yes** and all displays, Tournament Manager windows, Field Control programs, and the Tournament Server will shut down automatically.

**Note** - The Field Control and Tournament Server programs can be shut down by clicking (right-clicking on Windows) on the icons in the system tray (Windows) or menu bar (macOS) and choosing *Exit*. *Fig. *shows the icons that are used in the system tray by the Field Control and Tournament Server programs.
6. Advanced Topics

There are a number of advanced features and capabilities built in to the Tournament Manager designed for power users and for large events. This section will cover a number of these advanced features in more detail. None of the features discussed here are necessary for running a tournament, so if you are working with a small or medium tournament feel free to skip this section.

Sponsor Logos

The Tournament Manager has the ability to customize the Audience and Pit Display screens with graphics provided by the user. This feature is commonly used to place the logos of event sponsors on the screens as a method of recognition for their support. However, the feature is not restricted to sponsor logos and could be used, for example, to place a custom event logo on the screen. To access this feature, select the Tools ⇒ Options menu which will open the Options screen. Then, select the Sponsor Logos option from the list on the left. The Sponsor Logos Setup screen will appear which has 2 sections, Large Sponsor Images and Small Sponsor Images. There is also a preview area on the right.

Large Sponsor Images

The Large Sponsor Images section is used to load larger graphics and logos which will be shown on the Rankings, Schedule, and Logo screens. In each of these screens, the logo will be included in between the scrolling information. Graphics should be 1000 pixels wide. Graphics larger than 1000 pixels wide will be scaled to fit, however smaller graphics will not be enlarged. The graphics can be of any height, however 200 pixels tall or less will appear the best. Anything taller than this will be on-screen for a lengthy period of time which will interfere with viewers’ ability to see the desired rankings or scheduling information. Images should have either a white or transparent background for best appearance.

Small Sponsor Images

The Small Sponsor Images section is used to load small graphics and logos which will be shown on most of the display screens in the upper-right corner. Graphics should have a size of 172 by 100 pixels. Anything larger than this will be scaled to fit, however smaller graphics will not be enlarged. These images should have a transparent background for the best appearance.

Tip - Tournament Manager will search a default folder when you create a new database for sponsor images to load automatically. If you host many events using the same computer, you can put your logos in this directory so they will be automatically imported when a new tournament file is created. The folder on Windows is C: \ Users \ <username> \ AppData \ Roaming \ VEX Tournament Manager \ Sponsor Logos \ Small and C: \ Users \ <username> \ AppData \ Roaming \ VEX Tournament Manager \ Sponsor Logos \ Large. The folder on macOS is ~ / Library / Application Support / VEX Tournament Manager / Sponsor Logos / Small and ~ / Library / Application Support / VEX Tournament Manager / Sponsor Logos / Large.

Team Check In

For many events, it is important to keep track of teams as they arrive at the event. The Tournament Manager supports a Team Check In feature which assists with this effort. From the Main Window, the check in feature can be accessed by selecting Tools ⇒ Team Check In. This will bring up a separate dialog window that allows
you to enter team numbers and click **Check In** as they arrive. The Check In feature is also available in a tab in the Pit Admin window.

The Team List tab in the Main Window has a column showing whether each team has checked in or not. You can click on the column heading to sort the team list by check in status to easily see what teams have not yet checked in.

The final feature of Team Check In is in the Generate Matches page of the Tournament Setup Wizard. If you are generating matches and some teams have not been checked-in, you will be presented with an option to omit those teams from the qualification schedule. Using this feature, it is not necessary to remove teams who do not show up at your event from the team list.

**Note** - If you do not check in any teams, the Tournament Manager assumes that you are not using the feature and will not ask you about removing teams from the qualification match schedule.

**Inspection**

Another common task for larger events is keeping track of which teams have passed inspection. The Inspection feature of the Tournament Manager simplifies this process for inspectors and teams. To access the inspection interface, select **Tools ⇒ Inspection** from the Main Window or Pit Admin window.

The dialog that appears (Fig. 6-1) allows inspectors to enter the team number, inspection status, and any desired notes. An inspection status of Partially Complete is provided for teams that have begun inspection but have not yet passed.
Figure 6-1 - Inspection Dialog

The Pit Display contains a special screen for inspection. When this screen is selected, the status of each team at the event is shown. Teams that have not started inspection are shown in red. Teams who have started but not yet been passed (teams marked as Partially Complete) are shown in yellow. Teams who have passed are shown with strike-through to indicate they are done with inspection. This display allows inspectors and teams to easily monitor the progress of inspection.

Finally, if your event is using Field Queue Displays, then the inspection status will be visible on that display. When a match is queued, if any teams in the match have not yet passed inspection then those team numbers will be shown in yellow on the Field Queue Display. Most competitions require teams to pass inspection before competing in qualification matches, so this indicator can be used by field crews to identify teams which are not eligible to compete.

Multiple Divisions

Large events may wish to split the participating teams into multiple divisions. When an event is split into multiple divisions, each division plays a complete tournament, including qualification matches, alliance selection, and the elimination tournament. After all divisions complete their elimination tournaments, the winning alliance from each division enters into another elimination tournament which will determine a winning alliance for the overall event.

The Tournament Manager supports two methods for running multiple divisions. The first method is to run all the divisions completely separately and import them into a single Tournament File once each division finishes its elimination tournament. The second is to configure and run both divisions from a single Tournament File. With this method, all divisions must be networked together and they all connect to a single Tournament Server. The first method is preferred because it reduces the networking complexity and isolates each division such that a problem with one does not affect the other.

**Note** - VEX IQ divisions are handled differently than VRC divisions. The rankings for all division are combined and a single set of Finals matches are created for the top teams in the combined rankings.

**Tip** - Do not forget to plan for additional time for your elimination tournament if multiple divisions are used. If 2 divisions are used, then one additional round will be added (Event Finals). If 4 divisions are used, then two additional elimination rounds will be added (Event Semifinals and Event Finals).

Using Multiple Tournament Files

To set up a tournament with multiple divisions each in their own Tournament File, create, configure, and run each division as if it were a standard single division event containing the teams for each division. After finishing the elimination tournament for each division, determine which divisional Tournament File you will use for the event finals and copy the Tournament Files from each division to that computer. Import each division's Tournament File using the *File ⇒ Import Division* menu option in the Main Window. After importing each Tournament File, select the *File ⇒ Create Playoff Tournament* menu option in the Main Window; this option is used to create a playoff tournament from the winning alliances of multiple divisions. Select "Create New Division" from the "Division for Playoff" dropdown and give a name for the new division. Select each division in the dropdowns then click the "Create Bracket Playoff" button. Restart the Tournament Manager window and select...
the new division. The elimination matches for the new division will be automatically created and the elimination tournament can be played normally until a winning alliance for the full event is determined.

**Tip** - Make a copy of all divisional Tournament Files before beginning the import process. If there is a problem with the import, it is important to have the original copies of the Tournament Files.

## Using a Single Tournament File

To set up a tournament with multiple divisions in a single Tournament File, choose the *Large Event/Expert* option in the Tournament Setup Wizard. This will enable the *Division Setup* page (*Fig. 6-2*) later on in the wizard.

On the Division Setup page, use the dropdown to choose the number of divisions that will be present and provide a name for each division. Division names will be used throughout the tournament on Audience and Pit Displays as well as printed reports.

After the Division Setup page, the *Team Setup* page will be next. With multiple divisions enabled, the Team Setup page will look slightly different. Two new options, *Use single list for all divisions* and *Use separate lists for each division* will be present. If *Use single list for all divisions* is chosen, then you will provide one team list to the Tournament Manager and the Tournament Manager will randomly split that list into separate team lists for each division. If you wish to control which teams are placed into each division, then you will need to create individual team list .CSV files for each division and choose the *Use separate lists for each division* option. On the next wizard page, you will provide the team list or lists required based on your choices.

Continuing through the Setup Wizard, you will eventually come to the *Schedule Setup* page. This page is the same page that is used for a single division tournament (*Fig. 4-7*) with an additional area to control which division is assigned to each field set for each schedule block. Configure your schedule block start, end, and cycle time just as you would for a single division tournament. Before clicking the *Add* button, make sure that the division assignments for each field set is correct. You can click on the division name underneath each field set to get a dropdown menu where you can choose any division. This feature can be used for a lot of flexibility when setting up an event. For example, if you have 2 divisions named Engineering and Science, and two field sets named Main Arena and Side Arena, you can have Science play on the Main Arena field set and Engineering play on the Side Arena field set in the morning and then schedule a different block for the afternoon where the divisions switch and Engineering will play on the Main Arena and Science will play on the Side Arena.

Once you are finished with the wizard, the main Tournament
Manager will start. However, before the Main Window opens, you will see the Select Division dialog (Fig. 6-3). Each Tournament Manager window can only access one division at a time, so you must select which division you wish to access here. Use separate laptops for each division, and when starting up the Tournament Manager for the additional division make sure to connect them to the first division's Tournament Server by filling in the Remote IP and Password on the Connect dialog (seen in Fig. 4-11). There will only be one Tournament Data File and therefore only one Tournament Server for the whole event.

At this time each division should be set up and ready to begin. Play through each division just as you would for a single division tournament until winners (for VRC) or final rankings (for VEX IQ) for each division have been determined.

**Note** - The steps to create the finals tournament differ between VRC and VEX IQ events.

For a VRC or VEX U event, select the Matches ⇒ Create Playoff Tournament menu option in the Main Window; this option is used to create a playoff tournament from the winning alliances of multiple divisions. Select "Create New Division" from the "Division for Playoff" dropdown and give a name for the new division. Select each division in the dropdowns then click the "Create Bracket Playoff" button. Restart the Tournament Manager window and select the new division. The elimination matches for the new division will be automatically created and the elimination tournament can be played normally until a winning alliance for the full event is determined.

For a VEX IQ event, select the Matches ⇒ Create Finals Matches menu option in the Main Window; this option is used to create the Finals matches using the combined rankings from all divisions. The Finals matches will be created in a new 'Finals' division. Restart the Tournament Manager window and select the new 'Finals' division. The matches will be under the 'Finals' folder in the match tree.

**Built-In Web Server**

The Tournament Manager provides a built-in web server which can provide additional functionality for your event. The web server is started automatically when the Tournament Server is started.

The web site that is made available with the Tournament Web Server contains two sections. The first section provides tournament data such as rankings, match lists, and team lists. Anyone who can access the Tournament Web Server will be able to view this information. If desired, events can set up a wireless network which would allow teams to access this information from their own devices such as laptops, tablets, or phones. Setting up a network in this manner can be complicated and should be done by someone with networking expertise.

The second portion of the web site is an administrative section. This portion of the web site can be used by event staff to carry out certain tasks such as Team Check In and Inspection. These options are identical to the functionality built into the Tournament Manager application. This allows event staff to access these functions from devices which do not have the Tournament Manager installed. For example, a volunteer's laptop might be used at the pit administration table to enter team check in information. Another possibility is that with a properly-configured WiFi network, inspectors could enter inspection information from a handheld device such as an Android tablet or iPad while visiting a team's pit area.
Note - To access the administrative section of the tournament web site, login with the username admin. The password is the tournament password which was set in the Setup Wizard. It is important to make sure that this password is available only to authorized event staff.
League Play

League Play Concepts

A VEX League Event is composed of a series of league sessions which are held over a period of several weeks or months. Each league session is conducted like a qualification-only tournament, and once all league sessions are complete a league alliance selection process and elimination tournament are held.

Teams in a VEX League may not be required to attend all league sessions. In fact, some leagues may choose to limit teams from attending all league sessions in order to allow other teams to play as many matches as possible. Another feature of league play is that each team must play in a minimum percentage of available matches in the league in order to qualify for the league elimination tournament.

Running VEX League Events with Tournament Manager

When creating a new tournament that will be played as a league, be sure to click the checkbox to enable League Mode in the setup wizard (note: if you configured your event from a RobotEvents.com event code and TM code, league mode will be set automatically). Additionally, set the correct match percentage that teams must play to be eligible for the elimination tournament. If you are not sure what value to use, leave the default value or contact your REC Foundation Regional Support Manager. Finish the setup wizard by configuring your fields, matches, etc. as necessary for your first league session. At this point, your first league session is ready to play just like any other event.

When you are ready to play subsequent league sessions, start by opening the same tournament data file you created for the first league session. When you open the tournament file, you will be prompted to choose which league session you are playing. If the session you are not playing is not listed, you may add a new session. The tournament setup wizard will appear again allowing you to configure your teams, fields, and matches for your next league session. Any previous sessions are already stored in the tournament file and will be automatically included in the league rankings.

**Note** - In older versions of Tournament Manager, it was necessary to create new tournament data files for each league session and then import previous session data. This is no longer necessary and is now discouraged. Instead, the proper procedure is now to simply reuse the same tournament file at each league session, selecting the appropriate session each time when the file is opened. Matches for the current session can be regenerated at any time without affecting other sessions. Previous session data can be viewed by opening the tournament file and choosing the correct session. Be careful not to modify the previous session's data if you are opening old sessions!

Rankings at League Events

After the setup wizard is complete, the Tournament Manager will function similarly to other events. The only noticeable difference will be in the rankings - instead of Win Points, the Tournament Manager will display Win Percentage. Additionally, teams will be ranked according to the league play rankings tiebreakers. Teams which have played enough matches to qualify for the elimination tournament (according to the minimum percentage set in the setup wizard) will always be ranked above teams which have not yet qualified.

It is important to remember that league event rankings include all teams in the league, whether they are competing in the current session or not. The difference in rankings for league events may be confusing for teams that are accustomed to the rankings used at traditional VEX Robotics Competition events. Thus, it is important for the league event volunteers to understand these differences and be capable of explaining them if teams have questions.
**Alliance Selection and the Elimination Tournament**

Once the league sessions are complete, alliance selection can be conducted. Alliance selection and the elimination tournament can be conducted normally as described in Section 5, *Running An Event*.
Overview

VEX TEXT is a feature that allows teams to be alerted to upcoming matches using SMS text messages delivered directly to team members’ phones. VEX TEXT can complement queuing announcements and queue runners to help ensure teams report to the competition fields on time.

The VEX TEXT feature may be used by any official VEX Robotics Competition event. Each team at a VEX TEXT-enabled event is allowed to subscribe up to 3 mobile phone numbers to receive the text message notifications. For each match, the subscribed team members will receive 2 alerts, one 20 minutes prior to the match and one 10 minutes prior.

Note - In order to use the VEX TEXT feature, the computer running the Tournament Server needs to be connected to the Internet while the event is underway. Additionally, a separate computer with Internet access will be required at the Pit Admin or Registration table in order to sign teams up for the VEX TEXT system.

Setup Procedures

There are a few necessary steps that need to be taken to set up the VEX TEXT feature. Before you begin, make sure the computer hosting the Tournament Manager is set to the correct time and date. If the time and date are not correct, you could end up sending out incorrect match notifications. This will cause confusion and annoyance for the participating teams at your event, so please be sure to verify this prior to setting up VEX TEXT. Additionally, make sure the computer is able to access the Internet before you begin.

Next, your event must be listed on RobotEvents.com and the relevant information filled in on the General Setup page. Your Pit Admin or Team Registration table should be equipped with a laptop with Internet access. From there, you can access the VEX TEXT Control Panel at https://admin.vexscores.com. Log in using your Robot Events event code (SKU) and the Tournament Manager code (found on your Robot Events event administration page).

Note - Do not attempt to use the computer running the Tournament Manager to sign teams up for VEX TEXT. Use a separate computer with Internet access. No software installation is required on the signup computer since the signup process is done using a website only.
After logging in to the admin.vexscores.com website, you will be presented with the Team Signup page (Fig. 6-4). Select the team number from the dropdown and enter up to 3 mobile phone numbers which will receive text messages for the team specified. Verify that the numbers are correct to the best of your knowledge and that you have confirmed that all phone numbers belong to users at least 13 years old. After that, click Save. Once you successfully save the numbers, a text message will be sent to each number asking them to confirm the registration (this is to avoid sending a large number of unwanted SMS messages to a mis-typed phone number). The user can confirm their number by replying and putting the word "YES" in the message or visiting the URL that was sent as part of the sign-up message.

The final step necessary to use VEX TEXT is to enable text messages in the Tournament Manager Main Window. Select the Tools ⇒ Text Messages menu option and check the box to enable text messages. Make sure
you enable this check box at least 30 minutes before the first match to ensure that text messages for the first few matches go out on time. The Text Messages window will show information about text messages as they are sent, so it is a good idea to leave this window open during your event.

**Note** - If you shut down the Tournament Manager and restart it at a later time, text messages will be disabled and you will need to re-enable them. This is a safety feature to prevent accidentally sending out text messages at the wrong time. Also note that if you suspect anything is not right with the VEX TEXT system you can shut it down by unchecking the Enable box.

---

**Tournament Manager on the Raspberry Pi**

The Raspberry Pi is a series of small, inexpensive, single-board computers featuring multiple USB ports, an Ethernet network connection, and HDMI video output. The Tournament Manager display and field control software can be run on certain Raspberry Pi models, enabling low-cost displays and simplifying competition cabling.

Installing and configuring Tournament Manager on a Raspberry Pi is an advanced topic. Please ensure you are comfortable with the concepts described below before attempting to use this feature at a tournament.

**Raspberry Pi Tournament Manager Quick Start**

**Requirements**

- **Tip** - The Raspberry Pi product is just a bare circuit board. However, most vendors sell bundles that include a case, power supply, microSD card, and HDMI cable. It is recommended that you purchase one of these kits for convenience. Popular kit brands that have been used are CanaKit, Vilros, and LoveRPi. All of these are available on Amazon.com at the time of this writing (search for "Raspberry Pi 3 kit"). Some kits contain more equipment than others - make sure your kit contains everything below or you purchase the additional parts separately.

- A Raspberry Pi 2 or 3 model B with case and 2.5A power supply (Raspberry Pi 1, Zero, model A, etc. are not supported)
- A microSD card of at least 2GB in size (note: the SD card will be **completely erased** so ensure there is nothing on it that you wish to save)
- A display device (TV, computer monitor, or projector) which will be connected to the Raspberry Pi. The device must include an HDMI input and must support 1080P (1920x1080) resolution.
- A copy of the Tournament Manager Raspberry Pi software image which can be downloaded from the Tournament Manager website at [https://vextm.dwabtech.com](https://vextm.dwabtech.com)
- The most recent version of Tournament Manager running on a PC
- An Ethernet network connected to the Raspberry Pi and Tournament Manager PC that includes a DHCP server
- (Optional) VEXnet Field Control equipment

**Step 1 - Install Tournament Manager on SD card**
Important Note!
Installing Tournament Manager for the Raspberry Pi on will completely erase everything else on your microSD card! Make sure you are using the correct card and that you have saved anything important from the card first. It is recommended that you use a separate SD card specifically for Tournament Manager if you are sharing Raspberry Pis with other users.

After you finish downloading the Tournament Manager Raspberry Pi software image, you'll need to copy the software onto your microSD card to be used in the Raspberry Pi. This cannot be done using normal file copy operations on your PC. Instead, follow the instructions at https://www.raspberrypi.org/documentation/installation/installing-images/ to install the software to the SD card.

Note - The Tournament Manager Raspberry Pi software image will be used instead of the operating system listed on the web page referenced above. Please skip the steps on that page which refer to downloading an official Raspberry Pi image and use the Tournament Manager image instead.

Please be aware that the software images for the Raspberry Pi are large. The image file you download will be a ZIP file of approximately 300 MB. You will need to unzip that file to get the .img file inside. When unzipped, the .img file is approximately 900 MB, so be sure you have enough free hard drive space on your PC before attempting this step.

Step 2 - Connect cables and power on

Insert the SD card that you prepared in Step 1 into the Raspberry Pi. Connect the Raspberry Pi to the Ethernet network and the display device using the HDMI cable. If you intend to use this Raspberry Pi as a field queue display, you can also connect the VEXnet Field Control Board to one of the USB ports on the Raspberry Pi if desired. Finally, connect the power supply. As soon as power is connected the Raspberry Pi will begin booting up.

When the Raspberry Pi is first powered on, you should briefly see a multicolored square filling most of the display (this may not be observed if your display device takes a moment to wake up from sleep mode). The screen will then go black for a few seconds, and then you will see the Tournament Manager icon in the middle of the screen. The Tournament Manager icon indicates that the Raspberry Pi is in the process of starting the Tournament Manager software.

Once the Raspberry Pi finishes booting up, you will see a screen showing the VEX Robotics logo and the IP address of the Raspberry Pi. At this point you can continue with Step 3 to configure the Tournament Manager software on the Raspberry Pi.

Note - When the Raspberry Pi first starts up, you may see "<unknown>" on the display for a short time. This is normal as the Raspberry Pi attempts to obtain an IP address.
Step 3 - Configuring Tournament Manager

Once the Raspberry Pi is running and displaying an IP address, you can configure it from within Tournament Manager. Start Tournament Manager on your PC and select **Displays ⇒ Configure Remote Displays** in the menu bar. Your Raspberry Pi should be detected automatically and shown in the list. The **Refresh List** button can be used to re-scan for Raspberry Pis if yours was not detected right away. Alternately, click **Add Display** and type in the IP address shown on your Raspberry Pi to manually add it to the list.

Select your Raspberry Pi in the Remote Displays list. At the bottom of the window, select the type of display that you would like shown on the Raspberry Pi and choose the Field or Pit Display to be shown as appropriate. The Display Name field can be filled in to help you remember what each display is being used for. Finally, Overlay Mode determines whether this display will use a green-screen output meant for superimposing over live video. Select Off for this setting if you are not sure.

Once the settings are complete, click **Save Display Settings**. This will configure the Raspberry Pi and then a few moments later the Tournament Manager display will start. You can change the Raspberry Pi settings at any time and click **Save Display Settings** to restart the display.

**Note** - If you have trouble with the Raspberry Pi during an event, simply disconnect power for a moment and then plug it back in. The Raspberry Pi will take a minute or so to reboot and once it does, it will automatically reconnect to the Tournament Server. There is no need to reconfigure the Raspberry Pi if your Tournament Server has not changed.

**Note** - If you are running multiple tournaments at the same time on the same Ethernet network, you must configure each Raspberry Pi from the instance of Tournament Manager that you wish it to connect to. The Remote Displays list will show all Raspberry Pis even if they are not connected to the same tournament server.
Appendix A - Frequently Asked Questions

General

I just configured my event perfectly with the wizard, how can I share it with someone else or move it to another computer?

All of your event configuration information is stored in the Tournament Data File. This file can be copied to a different computer and opened with the Tournament Manager on that machine. To copy the Data File safely, use the File menu in the Main Window and select Save Copy of Tournament. This will save a copy of the current tournament information in a file that can be moved to a different computer and opened in the Tournament Manager there. You can move the file by emailing it, copying it to a USB thumb drive, or other method.

Once the Data File is located on the new computer, start up the Tournament Manager and when the Start or Connect to the Tournament Server window (Fig. 4-1) appears, use the Browse button to select the copied Data File.

Tip - Use the Save Copy of Tournament menu option to save a backup copy of the tournament data at key times during the event (before lunch, at the end of the day, before alliance selection, etc) to a USB memory stick or external hard drive. This way, if the scoring computer fails, you can restart the tournament on another machine to finish the event.

I accidentally overwrote my tournament settings. Is there any way I can recover them?

The Tournament Manager periodically saves backup copies of the Tournament Data File. You can access the folder where these backups are saved by selecting Automatic Backup Folder from the Tournament Manager folder in your Start menu. Make sure to look at the time listed on each file and select the one from a time when you know the settings were valid. Copy this file to somewhere else on your computer, restart the Tournament Manager, and select this file to open instead of the Tournament Data File you had initially created.

Note - The backup files contain the date and time when the backup was made in their filename to make it easy to find the correct backup file to use.

The computer that I’m running the Tournament Manager on failed during an event and won’t restart. Is there any way to recover my event information and settings?

If you used the Save Copy of Tournament option described above to save a copy to a USB memory stick or external hard drive, then you can start the Tournament Manager on another computer with that file to recover. Also, if you have any additional computers connected to the Tournament Manager (such as a Pit Display computer), then backups of the Tournament Data File will be saved remotely on those computers as well and can be accessed using the Automatic Backup Folder on that machine as described in the previous question. In this case, find the correct backup file and copy it to a spare computer that you can use to replace the failed machine.

Why don’t I hear any of the game sounds when I start and stop a match?

The game sounds are played from the Audience Display program. Make sure there is an Audience Display running
for the field set that is being controlled and that the volume on the computer is turned up sufficiently loud.

I adjusted the time zone on my computer and now all the match times are off by an hour. How do I fix this?

Matches are scheduled relative to the time zone set on the computer when the setup wizard is run. If you create matches with your computer set to one time zone and then subsequently adjust the time zone of the computer, your match times will be off. If you need to adjust the time on your computer after creating matches, do not adjust the time zone. Instead, just adjust the clock time to match the current local time while leaving the time zone configured as it was when the matches were created.

The match timer on the Audience Display sometimes freezes and then catches up, or sometimes the Pit Display disconnects. How can I fix this?

The network that you use to connect the various computers running the Tournament Manager together should be a hard-wired network. Wireless networks introduce delays which can interfere with the Tournament Manager connection, and therefore are not supported. Make sure to use a wired network between the computers running the Tournament Manager software whenever possible.

My event is running behind schedule and I don’t have enough time to run all of my qualification matches. Do I have to play all of them?

In order for the rankings to be calculated properly, you need to reduce the number of matches that count towards the rankings. Select Tools ⇒ Options in the menu bar and select the Qual. Matches option from the list on the left. Choose the appropriate number of qualification matches and click the OK button.

Note - If you do not change the number of qualification matches that count parameter and leave some matches unplayed, the rankings will be incorrect.

How do I run a VEX U scrimmage match during the down time of my High School / Middle School event?

Since the autonomous and driver control periods of a VEX U match are different from those of HS/MS matches, you cannot just run a regular match. Instead, queue up the Field Test Match and click the "Set Time" button in the Field Control window. Input the desired autonomous and driver control times, click the "OK" button, and start the match.

Alliance Selection

Can I change the number of elimination alliances or the number of teams per elimination alliance after qualification matches have started?

Yes, the settings for the number of elimination alliances and the number of teams per elimination alliance can be changed in the Options window under the Eliminations category any time up until alliance selection has started. To see the Options window, click on Tools ⇒ Options in the menu bar.

Is there a way to indicate that a team declined an invitation to join an alliance, allowing them to still be an alliance captain?
Yes, select the team as you normally would by double clicking the team or by clicking the Add Team button. When the dialog pops up, click the Decline button instead of the Accept button. The team will not be added to the alliance, will be ineligible to be selected by another alliance, but will retain its right to be an alliance captain.

**Can I make a team ineligible to participate in alliance selection?**

Yes, if there is a team that for some reason should not participate in alliance selection, you can mark them as ineligible. A team might be made ineligible because they left the competition early or have been disqualified by the referees.

After clicking the Start Alliance Selection button, in the popup window, check the box next to Mark teams ineligible before #1 captain is assigned. Now, in the team list on the left, highlight an ineligible team and click Make Team Ineligible. The team will appear in a lighter color in the team list. Continue this until all ineligible teams have been marked, and then click Continue alliance selection. Ineligible teams will not become alliance captains and are not allowed to be selected by other captains.

You can also make a team ineligible as long as they have not yet been assigned to an elimination alliance after you have started Alliance Selection. To do so, highlight the ineligible team on the left and click Make Team Ineligible. Again, the team will appear in a lighter color to indicate that they are not eligible.
Audience, Pit, and Field Displays

How do I display Skills Challenge rankings all the time on a dedicated screen?

Add an additional Pit Display in the Pit Display Setup window which can be found in the Setup Wizard or Options window. Start the Pit Display program on the computer that will be used for the Skills Challenge rankings and select the name of the new Pit Display that you just created in the Setup window. Finally, choose Pit Displays ⇒ (name of new display) from the menu bar to show the Pit Display Control window, and select SC Rankings in the control window.

Reports

Can I view reports without a printer installed?

Windows requires at least one printer to be set up (but not necessarily connected) on the computer that you wish to see reports. If you have a computer on which no printers have been installed, you can install a free software package called PDFCreator instead. PDFCreator provides a fake printer that allows you to print to a PDF file instead of a real printer. PDFCreator is available from http://www.pdfforge.org. An additional advantage of PDFCreator is that you can print reports to a PDF file and take them to a different computer to print, email them, or post them online.

Web Server

I tried to start the Tournament Web Server, but I got an error saying that the port is already in use. What do I do?

If another application is using the port that the Tournament Web Server, that application will need to be closed before the Tournament Web server can be used. Skype is known to use port 80, and exiting it will allow the Tournament Web Server to start properly.